Bugs/Issues after upgrade to XF2.1

Not on mobile, they aren’t. “Like” is still the only option.

Also weirdly on mobile the text editing box breaks my tablet’s automatic capital after period behavior.

—Patrick
Long-press "like" and you'll get the pop-up to choose a reaction.
 
Tweets still not showing up, but at least now there's a text link that says "This Tweet is unavailable." that i can click on to take me to then, so that's nice.
 

Dave

Staff member
Tweets still not showing up, but at least now there's a text link that says "This Tweet is unavailable." that i can click on to take me to then, so that's nice.
They show up for me. I wish I could help you but I can't replicate the issue.
 
I get the “this tweet is unavailable“ message also, but right under that (for me) it says “Disable your pop-up blocker and try again” or some such.

—Patrick
 
One minor annoyance I've found since the upgrade is that, on mobile, pressing the lightning bolt at the top takes me to What's New instead of New Posts. It's minor, but it's one more click that wasn't there before.
 

Dave

Staff member
One minor annoyance I've found since the upgrade is that, on mobile, pressing the lightning bolt at the top takes me to What's New instead of New Posts. It's minor, but it's one more click that wasn't there before.
I KNOW! I want to change that as well. I just don't know where to change it.
 

GasBandit

Staff member
I KNOW! I want to change that as well. I just don't know where to change it.
IIRC, the dude you paid to make the mod didn't give us any controls over it, and he was a dick about providing support later.
 

Dave

Staff member
One minor annoyance I've found since the upgrade is that, on mobile, pressing the lightning bolt at the top takes me to What's New instead of New Posts. It's minor, but it's one more click that wasn't there before.
FIXED! Holy shit! FIXED!!

(Asked over at Xenforo.com and someone linked to an addon that works!)
 
5-6 attempts on mobile, no errors.
Multiple attempts on desktop, also no errors.

--Patrick
 

GasBandit

Staff member
The error actually seemed to be generated when trying to invoke the default like handler from the reactions. Getting rid of that seems to make it behave.
 

Dave

Staff member
Okay so we actually have TWO Reactions addons running. The old one that wasn't supposed to work after the change but did, and the new one that was supposed to work but didn't. I don't know why they are working together - I couldn't get either to work right on their own - but I'm not touching shit.
 

GasBandit

Staff member
What'd you do, man?!?
I reinstalled the one that was uninstalled and decoupled the whole mess from the default like handler.

Important to note that it's still kinda broke because the reaction control panel doesn't show up on the left of the admin panel like it's spose'ta. You gotta click the reactions button below the charts on the main admin content page.
 
Xenblue, mobile, chrome. But it's working fine. My issues were me not understanding UI. The "I hate this" was because I keep having problems figuring it out with each change.
 
What, was there something wrong with the old "pun/sad/funny" icons?

--Patrick
 
I figured out what was blocking teh tweets, it was the DuckDuckGo Privacy Essentials add-on, which i got who knows when...

Didn't even think to look at add-ons, i stumbled upon them by mistake this morning when pressing the wrong thing...
 

Dave

Staff member
I told you Duck Duck Go was blocking mine before! Whenever I have to unblock a site I have to do uBlock Origin, Ghostery, DuckDuckGo, & Privacy Badger.

If an ad gets through my screen I just stand up and clap. They've earned it.
 
Yeah, but i didn't see DDG since it's not in any of the tool or menu bars, and i even forgot i installed it (i still don't remember, really), and uBlock is fine for me.

The second i saw it i knew that must be it.

Of course, as i've said before, last time the tweets started working without me turning it off, so it must be something more then just it blocking the links.

Oh well, at least now i know.
 
Did the reactions addon get borked? The reactions received by a post aren't showing correctly, and there's no longer anywhere to click to give a reaction.

1583306034790.png
 

Dave

Staff member
The fuck?

edit: Nothing changed so I wonder what happened. Not going to do a thing until Gas looks at it first.
 
Top